using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^[^-]{0,100}-[^-]{0,100})-";
string substitution = @"\n";
string input = @"Part1-part2-part3-part4-part5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}