const regex = /(?<=^[^-]{0,100}-[^-]{0,100})-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^[^-]{0,100}-[^-]{0,100})-', 'gm')
const str = `Part1-part2-part3-part4-part5`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);