use strict;
my $str = 'Part1-part2-part3-part4-part5';
my $regex = qr/(?<=^[^-]{0,100}-[^-]{0,100})-/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";