using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(bmp|gif|png|jpg|jpeg)$";
string substitution = @".\1.gz";
string input = @"foo.bmp
bar.gif";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}