package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.(bmp|gif|png|jpg|jpeg)$`)
var str = `foo.bmp
bar.gif`
var substitution = ".\1.gz"
fmt.Println(re.ReplaceAllString(str, substitution))
}