$re = '/\.(bmp|gif|png|jpg|jpeg)$/m';
$str = 'foo.bmp
bar.gif';
$subst = ".\1.gz";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;