import Foundation
let pattern = #"\.(bmp|gif|png|jpg|jpeg)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo.bmp
bar.gif
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".\1.gz"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)