$re = '/"(\w+)/';
$str = 'this is my sentence \\"course of math\\" of this year';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;