use strict;
my $str = '# Etykieta na przycisku Usuń kanał.
label_button_delete_channel = Usuń ten kanał
# Przycisk etykieta save zmiany kanału.
label_button_save_channel = Zapisz zmiany
# Etykieta na przycisk używany do wysyłania kanału zaprosić.
label_button_send_invite_channel = Wyślij zaprosić
# Wiadomość dla użytkownika przed wysłaniem zaproszenia do kanału.
msg_send_invite_channel = link aktywacyjny zostanie wysłany na adres e-mail. Odbiorca musi w link w mailu, i potwierdzić aktywację.
# Sekcja konfiguracji Homecoming Komunikat pomocy.
label_homecoming_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji, w przypadku gdy ktoś wraca do domu.
# Pomoc wiadomość systemt sekcji konfiguracji zdrowia.
label_systemhealth_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji w przypadku, gdy system wymaga uwagi.
# Sekcja konfiguracji dzienników Komunikat pomocy połączeń.
label_calllogs_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji w przypadku otrzymania wydarzenie rejestr połączeń podczas twojej nieobecności.
# Sekcja konfiguracji powiadomienia Komunikat pomocy.
label_notifications_configuration_description = Możesz skonfigurować, którzy zostaną powiadomieni przez system elementów Gigaset poprzez powiadomienia Push lub e-mail, gdy ktoś przychodzi do domu lub system wymaga uwagi lub zdarzenie rejestru połączeń zostanie odebrany podczas twojej nieobecności.
# Tekst # Etykieta na adres e-mail powiadomienia e-mail
label_email_channel_address = Adres e-mail
# Etykieta na informację, tytułu w sekcji konfiguracji
label_email_notifications = Powiadomienia e-mail
# Opis powiadomień e-mail przycisk pomóc
label_notifications_email_configuration = Możesz skonfigurować, którzy zostaną powiadomieni przez system elementów Gigaset poprzez e-mail, gdy ktoś przychodzi do domu lub system wymaga uwagi lub zdarzenie rejestru połączeń zostanie odebrany podczas twojej nieobecności.
# Tekst do wyświetlenia w tabeli opcji wejść na progu
label_zone_threshold_title = Próg
# Tekst na ekranie o tytuł progu strefy
label_zone_threshold_screen_title = Próg Strefa
label_lang_pl = Polski';
my $regex = qr/^(.*[a-zA-Z_0-9] = [a-zA-Z0-9 óńęąłśćżź\-.,?'":\\/<>_\(\)\!=]+)|(#[a-zA-Z0-9 ÓŃĘĄŁŚĆŻŹóńęąłśćżź\-.,?'":\\/<>_\(\)\!=]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}