# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*[a-zA-Z_0-9] = [a-zA-Z0-9 óńęąłśćżź\-.,?'\":\\/<>_\(\)\!=]+)|(#[a-zA-Z0-9 ÓŃĘĄŁŚĆŻŹóńęąłśćżź\-.,?'\":\\/<>_\(\)\!=]+)$"
test_str = ("# Etykieta na przycisku Usuń kanał.\n"
"label_button_delete_channel = Usuń ten kanał\n"
"# Przycisk etykieta save zmiany kanału.\n"
"label_button_save_channel = Zapisz zmiany\n"
"# Etykieta na przycisk używany do wysyłania kanału zaprosić.\n"
"label_button_send_invite_channel = Wyślij zaprosić\n"
"# Wiadomość dla użytkownika przed wysłaniem zaproszenia do kanału.\n"
"msg_send_invite_channel = link aktywacyjny zostanie wysłany na adres e-mail. Odbiorca musi w link w mailu, i potwierdzić aktywację.\n"
"# Sekcja konfiguracji Homecoming Komunikat pomocy.\n"
"label_homecoming_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji, w przypadku gdy ktoś wraca do domu.\n"
"# Pomoc wiadomość systemt sekcji konfiguracji zdrowia.\n"
"label_systemhealth_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji w przypadku, gdy system wymaga uwagi.\n"
"# Sekcja konfiguracji dzienników Komunikat pomocy połączeń.\n"
"label_calllogs_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji w przypadku otrzymania wydarzenie rejestr połączeń podczas twojej nieobecności.\n"
"# Sekcja konfiguracji powiadomienia Komunikat pomocy.\n"
"label_notifications_configuration_description = Możesz skonfigurować, którzy zostaną powiadomieni przez system elementów Gigaset poprzez powiadomienia Push lub e-mail, gdy ktoś przychodzi do domu lub system wymaga uwagi lub zdarzenie rejestru połączeń zostanie odebrany podczas twojej nieobecności.\n"
"# Tekst # Etykieta na adres e-mail powiadomienia e-mail\n"
"label_email_channel_address = Adres e-mail\n"
"# Etykieta na informację, tytułu w sekcji konfiguracji\n"
"label_email_notifications = Powiadomienia e-mail\n"
"# Opis powiadomień e-mail przycisk pomóc\n"
"label_notifications_email_configuration = Możesz skonfigurować, którzy zostaną powiadomieni przez system elementów Gigaset poprzez e-mail, gdy ktoś przychodzi do domu lub system wymaga uwagi lub zdarzenie rejestru połączeń zostanie odebrany podczas twojej nieobecności.\n"
"# Tekst do wyświetlenia w tabeli opcji wejść na progu\n"
"label_zone_threshold_title = Próg\n"
"# Tekst na ekranie o tytuł progu strefy\n"
"label_zone_threshold_screen_title = Próg Strefa\n"
"label_lang_pl = Polski")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.