import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!$)(?!0+$)\\d{0,5}(?:\\.(?!0{1,2}$)\\d{1,2})?$";
final String string = "12345.12\n"
+ "0.12\n"
+ "00000.0\n"
+ "00000\n"
+ "00000.01\n"
+ "00001\n"
+ "00000.00\n"
+ "00000.000\n"
+ "12345.89\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}