# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=@)\S+//g;t' <<< "abasc@firstreoblcicmc.do.com"