#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((0[1-9]|[1-4][0-9]|5[0-6])( +|$)){6}(?<! )$"
Local $sString = "33 44 51 52 53 56 " & @CRLF & _
"33 44 51 52 53 59" & @CRLF & _
"33 44 51 52 55 55" & @CRLF & _
"00 00 00 00 00 00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")