using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?\b[1-9][0-9]*\b";
string input = @"-90
90
-0
-00
1
-1
0
00
+2 This is a test 2 and -10 with 0 and +10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}