re = /<a[^>]*class=\s?['"]\s?whtbigheader\s?['"][^>]*>(.*?)<\/a>/i
str = '<A HREF=\'/articles/0,7340,L-4664450,00.html\' CLASS=\'whtbigheader\' style=\'color:#FFFFFF;\' HM=1>need to get this value</A>";
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end