re = /^((?!.*email).)*thank(\-|\_|)you.*/i
str = 'http://www.safesteptub.com/thank-you
http://www.safesteptub.com/email/thank-you/
NOTE:
Newlines are excluded as well. Please make sure the string you want to test is at the top of the list.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end