package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\+7|8)(\(\d{3}\)|\d{3})\d{7}$`)
var str = `88121234567`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}