using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-F0-9]+)((\.[A-Za-z0-9]+)*)$";
string input = @"3051DFC10CBA8E5532404230727036.route123";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}