package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-F0-9]+)((\.[A-Za-z0-9]+)*)$`)
var str = `3051DFC10CBA8E5532404230727036.route123`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}