$re = '/^([A-F0-9]+)((\.[A-Za-z0-9]+)*)$/';
$str = '3051DFC10CBA8E5532404230727036.route123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);