import Foundation
let pattern = #"^([^|]*)\|0\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"WISEMAN·CINDY|0|29.98|THE·OZARK·FOOD·COOPERATIVE·EXCHANGE|9/30/2013·UT04·‐·Capital·Credit·Distributions|20464721"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}