#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:opc.tcp|https|http):\/\/(\S+):\d+[\/\w]*"
Local $sString = "https://198.10.157.14:4814/fdggfh/fdhgdsf/gnhdfg" & @CRLF & _
"" & @CRLF & _
"opc.tcp://198.10.157.14:4814/fdggfh/fdhgdsf/gnhdfg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"address 192.168.1.1" & @CRLF & _
" netmask 255.255.255.0" & @CRLF & _
" gateway 192.168.1.254" & @CRLF & _
"" & @CRLF & _
"=[\w\W]*(auto[\w\W]*eth2\s+inet\s+(dhcp|static)\s*((?:address\s+\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\s+(?:netmask\s+\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\s+(?:gateway\s+(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})))?)" & @CRLF & _
"" & @CRLF & _
"auto eth2" & @CRLF & _
"iface eth2 inet static" & @CRLF & _
" address 192.168.1.1" & @CRLF & _
" netmask 255.255.255.0" & @CRLF & _
" gateway 192.168.1.254" & @CRLF & _
"pre-up /sbin/ifconfig $IFACE mtu 1450" & @CRLF & _
"" & @CRLF & _
"auto eth3" & @CRLF & _
"iface eth3 inet static" & @CRLF & _
" address 192.168.1.1" & @CRLF & _
" netmask 255.255.255.0" & @CRLF & _
" gateway 192.168.1.254" & @CRLF & _
"" & @CRLF & _
"= ([\d\.]+)(\w?)\s+\d+%.*" & @CRLF & _
"/dev/sda1 ff 55 7sg233 fgd 3.7G 4.0K 3.7G 0% /mnt/sda1 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <?xml version="1.0" encoding= "utf-8"?>" & @CRLF & _
"<confi guration>" & @CRLF & _
"" & @CRLF & _
"[\w\W]*(auto[\w\W]*eth2\s+inet\s+(dhcp|static)\s+((?:address\s+\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})?\s*(?:netmask\s+\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})?\s*(?:gateway\s+(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}))?)?\s+(pre-up \/sbin\/ifconfig \$IFACE mtu \d{3,4}\s+))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")