$re = '/(?:opc.tcp|https|http):\/\/(\S+):\d+[\/\w]*/';
$str = 'https://198.10.157.14:4814/fdggfh/fdhgdsf/gnhdfg
opc.tcp://198.10.157.14:4814/fdggfh/fdhgdsf/gnhdfg
address 192.168.1.1
netmask 255.255.255.0
gateway 192.168.1.254
=[\\w\\W]*(auto[\\w\\W]*eth2\\s+inet\\s+(dhcp|static)\\s*((?:address\\s+\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})\\s+(?:netmask\\s+\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})\\s+(?:gateway\\s+(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})))?)
auto eth2
iface eth2 inet static
address 192.168.1.1
netmask 255.255.255.0
gateway 192.168.1.254
pre-up /sbin/ifconfig $IFACE mtu 1450
auto eth3
iface eth3 inet static
address 192.168.1.1
netmask 255.255.255.0
gateway 192.168.1.254
= ([\\d\\.]+)(\\w?)\\s+\\d+%.*
/dev/sda1 ff 55 7sg233 fgd 3.7G 4.0K 3.7G 0% /mnt/sda1
<?xml version="1.0" encoding= "utf-8"?>
<confi guration>
[\\w\\W]*(auto[\\w\\W]*eth2\\s+inet\\s+(dhcp|static)\\s+((?:address\\s+\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})?\\s*(?:netmask\\s+\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})?\\s*(?:gateway\\s+(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}))?)?\\s+(pre-up \\/sbin\\/ifconfig \\$IFACE mtu \\d{3,4}\\s+))';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);