$re = '/[A-Fa-f{64}]/';
$str = '6e8bf00e05ed6877dd9ce04b2d93a8d00261db7de1bac5ac744b2e92219485ad';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);