using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*webnovel\.com\/(vote|book\/[0-9]+\/[^0-9]*|rssbook\/.*|)";
string input = @".*webnovel\.com\/(vote|book\/\d+\/\D*|rssbook\/.*|)
https://www.webnovel.com/book/6838665602002705/23700208386889837/The-Avalon-Of-Five-Elements/Break-Even
https://www.webnovel.com/book/8102217006003305/22972070770045319/Ultimate-Scheming-System/Buddha%E2%80%99s-Fiery-Lotus,-Explode!
https://www.webnovel.com/rssbook/8102217006003305/22972070770045319
https://www.webnovel.com/
https://www.webnovel.com/book/6838665602002705/The-Avalon-Of-Five-Elements
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}