import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*webnovel\\.com\\/(vote|book\\/[0-9]+\\/[^0-9]*|rssbook\\/.*|)";
final String string = ".*webnovel\\.com\\/(vote|book\\/\\d+\\/\\D*|rssbook\\/.*|)\n\n\n"
+ "https://www.webnovel.com/book/6838665602002705/23700208386889837/The-Avalon-Of-Five-Elements/Break-Even\n\n"
+ "https://www.webnovel.com/book/8102217006003305/22972070770045319/Ultimate-Scheming-System/Buddha%E2%80%99s-Fiery-Lotus,-Explode!\n\n"
+ "https://www.webnovel.com/rssbook/8102217006003305/22972070770045319\n\n"
+ "https://www.webnovel.com/\n\n"
+ "https://www.webnovel.com/book/6838665602002705/The-Avalon-Of-Five-Elements\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}