use strict;
my $str = '.*webnovel\\.com\\/(vote|book\\/\\d+\\/\\D*|rssbook\\/.*|)
https://www.webnovel.com/book/6838665602002705/23700208386889837/The-Avalon-Of-Five-Elements/Break-Even
https://www.webnovel.com/book/8102217006003305/22972070770045319/Ultimate-Scheming-System/Buddha%E2%80%99s-Fiery-Lotus,-Explode!
https://www.webnovel.com/rssbook/8102217006003305/22972070770045319
https://www.webnovel.com/
https://www.webnovel.com/book/6838665602002705/The-Avalon-Of-Five-Elements
';
my $regex = qr/.*webnovel\.com\/(vote|book\/[0-9]+\/[^0-9]*|rssbook\/.*|)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}