# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*webnovel\.com\/(vote|book\/[0-9]+\/[^0-9]*|rssbook\/.*|)"
test_str = (".*webnovel\\.com\\/(vote|book\\/\\d+\\/\\D*|rssbook\\/.*|)\n\n\n"
"https://www.webnovel.com/book/6838665602002705/23700208386889837/The-Avalon-Of-Five-Elements/Break-Even\n\n"
"https://www.webnovel.com/book/8102217006003305/22972070770045319/Ultimate-Scheming-System/Buddha%E2%80%99s-Fiery-Lotus,-Explode!\n\n"
"https://www.webnovel.com/rssbook/8102217006003305/22972070770045319\n\n"
"https://www.webnovel.com/\n\n"
"https://www.webnovel.com/book/6838665602002705/The-Avalon-Of-Five-Elements\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.