import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\(\\d+\\)\\s?\\d*|\\d+)([-\\/ ]\\d+){1,3}";
final String string = "800-569-0123,\n"
+ "1-866-523-4176,\n"
+ "(324)442-9843,\n"
+ "(212) 332-1200,\n"
+ "713/853-5620,\n"
+ "713 853-0357,\n"
+ "713 837 1749,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}