import Foundation
let pattern = #"(.?)([fds]|(?<!t|^.)r)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
d45
f45
s66
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)