package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\w+,){3}(.*)`)
var str = `fields:hello world
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}