using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\{((?:(?:[A-z]+(?:\.[A-z0-9()\[\]\""]+)*)+|(?:\""[\w/?.&=_\-]*\"")+)+)}+$";
string input = @"${test.one}${test.two}
${test.one}${test.two()}
${test.one}${""hello""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}