# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|\s)_my-cookie-key\=([^\;]+)/$1/mg;t' <<< "_my-cookie-key=expected value; _key2=value 2; key3=value 3;
_key1=value 1; _my-cookie-key=expected value; key3=value 3;
_key1=value 1; key2=value 2; _my-cookie-key=expected value;"