#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^|\s)_my-cookie-key\=([^\;]+)"
Local $sString = "_my-cookie-key=expected value; _key2=value 2; key3=value 3;" & @CRLF & _
"_key1=value 1; _my-cookie-key=expected value; key3=value 3;" & @CRLF & _
"_key1=value 1; key2=value 2; _my-cookie-key=expected value;"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)