use strict;
my $str = '_my-cookie-key=expected value; _key2=value 2; key3=value 3;
_key1=value 1; _my-cookie-key=expected value; key3=value 3;
_key1=value 1; key2=value 2; _my-cookie-key=expected value;';
my $regex = qr/(?:^|\s)_my-cookie-key\=([^\;]+)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";