$re = '/(?:^|\s)_my-cookie-key\=([^\;]+)/m';
$str = '_my-cookie-key=expected value; _key2=value 2; key3=value 3;
_key1=value 1; _my-cookie-key=expected value; key3=value 3;
_key1=value 1; key2=value 2; _my-cookie-key=expected value;';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;