# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|\s)_my-cookie-key\=([^\;]+)"
test_str = ("_my-cookie-key=expected value; _key2=value 2; key3=value 3;\n"
"_key1=value 1; _my-cookie-key=expected value; key3=value 3;\n"
"_key1=value 1; key2=value 2; _my-cookie-key=expected value;")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.