$re = '/(\\\\([\bfs\b|\blang\b|\bri\b]*\d{2,4}|\s))/m';
$str = '
\\fs14 (font size 14)
\\ri240 (right indent)
\\lang1033 (applies a language to a character)
\\lang1033
\\
\\
\\hello !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);