#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?:https?):\/\/)([a-z-A-Z0-9+&@#\/%=~_|$?!:,.]*[a-zA-Z0-9+&@#\/%=~_|$])[\?]{1}([a-zA-Z0-9+&@#\/%=~_|$,]+)"
Local $sString = "https://my.t-mobile.com/plans/ondevicefulfillment.html?productType=INDIVIDUAL&productId=SOC1,SOC2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")