package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:https?):\/\/)([a-z-A-Z0-9+&@#\/%=~_|$?!:,.]*[a-zA-Z0-9+&@#\/%=~_|$])[\?]{1}([a-zA-Z0-9+&@#\/%=~_|$,]+)`)
var str = `https://my.t-mobile.com/plans/ondevicefulfillment.html?productType=INDIVIDUAL&productId=SOC1,SOC2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}