using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!https:\/\/activate\.careguidelines\.com).*";
string input = @"https://activate.careguidelines.com/products/getproducts.asmx?wsdl
https://test.careguidelines.com/products/getproducts.asmx?wsdl
https://activate.careguidelines.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}