import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!https:\\/\\/activate\\.careguidelines\\.com).*";
final String string = "https://activate.careguidelines.com/products/getproducts.asmx?wsdl\n\n"
+ "https://test.careguidelines.com/products/getproducts.asmx?wsdl\n\n"
+ "https://activate.careguidelines.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}