#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((["'])(?:(?=(\\?))\3.)*?),\2"
Local $sString = "1070,17,2,GN3-670,"COLLAR B, M STAY,","2,606.45" "
Local $sSubst = "$1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)