using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([""'])(?:(?=(\\?))\3.)*?),\2";
string substitution = @"$1""";
string input = @"1070,17,2,GN3-670,""COLLAR B, M STAY,"",""2,606.45"" ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}