import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(@embed(?:(?>(?:(?!@embed|@endembed).)+)*|(?1))*@endembed))";
final String string = "@extends('layouts/default')\n\n"
+ "@section('content')\n"
+ " <div class=\"row\">\n"
+ " <div class=\"col-md-6\">\n"
+ " @embed('components/box')\n"
+ " @section('title', 'Box title')\n"
+ " @section('content')\n"
+ " <h4>Haai</h4>\n"
+ " Box content\n"
+ " @stop\n"
+ " @endembed\n"
+ " </div>\n"
+ " <div class=\"col-md-6\">\n\n"
+ " @embed('components/box')\n"
+ " @section('title', 'Box2 title')\n"
+ " @section('content')\n\n"
+ " @embed('components/timeline')\n"
+ " @section('items')\n"
+ " @stop\n"
+ " @endembed\n\n"
+ " @stop\n"
+ " @endembed\n"
+ " </div>\n"
+ " </div>\n"
+ "@stop";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}