# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(@embed(?:(?>(?:(?!@embed|@endembed).)+)*|(?1))*@endembed))"
test_str = ("@extends('layouts/default')\n\n"
"@section('content')\n"
" <div class=\"row\">\n"
" <div class=\"col-md-6\">\n"
" @embed('components/box')\n"
" @section('title', 'Box title')\n"
" @section('content')\n"
" <h4>Haai</h4>\n"
" Box content\n"
" @stop\n"
" @endembed\n"
" </div>\n"
" <div class=\"col-md-6\">\n\n"
" @embed('components/box')\n"
" @section('title', 'Box2 title')\n"
" @section('content')\n\n"
" @embed('components/timeline')\n"
" @section('items')\n"
" @stop\n"
" @endembed\n\n"
" @stop\n"
" @endembed\n"
" </div>\n"
" </div>\n"
"@stop")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.