$re = '/^.* ((?:([12])|(3)|([45]))\d{4}) .*/m';
$str = 'Blah 12345 Blah
Blah 22345 Blah
Blah 32345 Blah
Blah 42345 Blah
Blah 52345 Blah';
$subst = "(?2AAA:(?3BBB:XYZ))$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;