const regex = /(label(:|\+))?(\w+)(?:_(\d+))?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(label(:|\\+))?(\\w+)(?:_(\\d+))?', 'gi')
const str = `group_12.label:sub_1.field_23.label+long_field.label:another.label+long_field_345
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}