$re = '/(^|\s)#(\w+)/';
$str = '#life random string #life
#apple ##apple
#apple#fruit
#life #oranges #fruits #sandwiches #fruit';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;