using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((1*),\3)|((1*),((\5)1+))|((1*),((?!\9)1+)))$";
string substitution = @"$2|$5,$6|$9,$10";
string input = @"111111,11111";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}